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1. FEJEZET
Bevezető
Paralleliser - A párhuzamosítás megvalósítása
A
Paralleliser programmal absztrakt programokat párhuzamosíthatunk. A program Halász Attila diplomamunkájában megfogalmazott ötletének második és harmadik részfeladatát valósítja meg számítógépen.
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1.1. ábra A második és harmadik részfeladat.
A program célja
A program elsődleges célja, hogy a felhasználó az általa elkészített soros feldolgozású absztrakt programból párhuzamos programot nyerjen. További cél, hogy a programot lássuk a képernyőn, beállíthassuk az átalakításhoz szükséges paramétereket, képet kapjunk az elért gyorsulásról és elmenthessük az eredményként kapott párhuzamos programot.
1. Lépés - A program telepítése
Ellenőrizzük, hogy teljesülnek-e a program rendszerkövetelményei:

· Pentium 100, 16 MB RAM

· Merevlemez, CD-ROM meghajtó és egér

· 1 MB SVGA videokártya

· 32 bites MS Windows operációs rendszer (95/98/NT/2000/XP)
· Microsoft Visio

Ajánlott programok:

· Microsoft Visual Studio 2005

· Microsoft Visio for Enterprise Architects
2. FEJEZET
Ha a program lemezét betesszük a CD meghajtóba, a telepítő magától elindul. Amennyiben ez a lehetőség le van tiltva rendszerünkben valamilyen okból, akkor a telepítést a CD gyökérkönyvtárában található SETUP.EXE program indításával kezdeményezhetjük.

A telepítőprogram átmásolja a program fájljait a merevlemezünkre, valamint elkészíti a program futtatásához szükséges indítóikont a Start menübe.
2. Lépés - A program indítása
A telepített programot a

Start menü > Programok > Halász Attila > Paralleliser
menüpontból futtathatjuk.
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2.1. ábra A program indítása a Start menüből

3. Lépés - Bemeneti program kiválasztása

A futó alkalmazás menüsorából a

File > Open…

menüpontra vagy az eszköztár [image: image3.png]


 ikonjára kattintva egy soros feldolgozású absztrakt program betöltését kezdeményezhetjük. Ilyen program előállításáról a későbbiekben olvashatunk, most válasszuk ki az előre telepített példaprogramok közül az „Example_1.vdx” nevű fájlt.

Ezután a választott program osztálydiagramja és egyetlen függvényének (főprogramjának) folyamatábrája betöltődnek a főablak Microsoft Visio fájl megjelenítőjébe.
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2.2. ábra Example_1.vdx - Az első példaprogram
A Visio megjelenítőjében megnézhetjük a folyamatábrát, ha az alsó sávban a függvény fülére kattintunk.
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2.3. ábra A függvény folyamatábrájának előhívása

4. Lépés - A program gráf megjelenítése
Kattintsunk a menüben a

View > Program Graph

menüpontra vagy az eszköztár [image: image6.png]


 ikonjára. A felugró ablakban megjelenik a betöltött program gráfja. A jobb olvashatóság érdekében nagyíthatjuk az ablakot. Az elemek ismertetését a diplomamunka 3. fejezetében olvashatjuk.
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2.4. ábra A program gráf ablak
Tanulságos lehet a program gráf megtekintése a párhuzamosítás után, érdemes összevetni a párhuzamosítás előttivel. Ehhez a program gráfot elmenthetjük a

File > Save Program Graph As EMF

menüponttal, vagy az eszköztár [image: image8.png]


 ikonjával. Ez a művelet egy Windows által támogatott fájlt hoz létre, amit külső képnézegetővel is megnézhetünk, mint pl. a Windows Picture and Fax Viewer alkalmazás. Ha a gráfot más gráfmegjelenítővel szeretnénk megnézni, amely ismeri a „.dot” fájlformátumot, akkor a

File > Save Program Graph As DOT

menüpontra, vagy az eszköztár [image: image9.bmp] ikonjára kattintsunk.

5. Lépés - A programjellemzők beállítása
A gráf megtekintése, elmentése után kattintsunk a menüben az

Edit > Settings

menüpontra, vagy az eszköztár [image: image10.png]


 ikonjára. Egy beállító panelhoz jutunk, ahol megadhatjuk műveletek időigényét, pl. hogy egy változó értékének kiolvasása, vagy egy új szál létrehozása mennyi időbe kerül. Állítsuk át a változó értékének beállításához (variable set) tartozó időegységet (time units) az alapértelmezett egyről kettőre, majd kattintsunk az OK gombra, ezzel módosítottuk a statisztika számításához szükséges adatokat.
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2.5. ábra Az időigényeket beállító ablak
6. Lépés - A program párhuzamosítása
A program párhuzamosítását a megadott időegység beállításokkal az

Edit > Parallelise
menüpontból, vagy az eszköztár [image: image12.png]


 ikonjára kattintva kezdeményezhetjük. Az ikon kifakulása [image: image13.png]


 jelzi számunkra, hogy a párhuzamosítás végbement, ekkor már nem párhuzamosíthatjuk tovább a programot.
7. Lépés - A párhuzamos program mentése
A párhuzamos programot a
File > Save As…

menüpontból, vagy az eszköztár [image: image14.png]


 ikonjával menthetjük el. A szebb képi elrendezés érdekében töltsük be az elmentett programot a Microsoft Visio programba, alul lépjünk a függvény fülre, majd a menüben a
Shape > Lay Out Shapes…

menüpont segítségével a Visio automatikusan elrendezi nekünk az elemeket jobban átlátható formába.
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2.6. ábra A Microsoft Visio programba betöltött és automatikusan kiigazított párhuzamos megoldás
Ezután az ábrát tovább szerkeszthetjük még kézzel, a végén mentsük el, és ezzel megkaptuk a párhuzamos program folyamatábráját.

8. Lépés - A becsült gyorsulás megtekintése
A soros és párhuzamos programról készített statisztikát a

View > Statistics

menüpontra, vagy az eszköztár [image: image16.png]


 ikonjára kattintva érhetjük el. Ekkor egy felugró ablakban láthatjuk a soros feldolgozású (sequential) és a párhuzamos (parallel) programról készített időbecslést, valamint megtudhatjuk, hogy a párhuzamosítás milyen becsült gyorsulással jár (calculated avarage speedup). Jelen példánkban az átállított, változókra vonatkozó időegységgel a gyorsulást a program 450 %-osra becsüli, azaz a párhuzamos program közel ötször gyorsabb a sorosnál. Ez a becslés fejben követve is reálisnak tűnik, mert öt párhuzamosított folyamatunk van, de ezek végrehajtási ideje némileg különbözik, és emiatt nem lett a gyorsulás tisztán ötszörös.
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2.7. ábra A statisztikát megjelenítő ablak
3. FEJEZET
Helyes bemeneti program készítése
A program speciálisan felépített Microsoft Visio fájlokkal dolgozik, ebben a fejezetben megismerhetjük azok elemeit és elkészítési módjukat. A továbbiakban feltételezett némi objektumelvű programozással kapcsolatos ismeret (osztály, öröklődés, adattagok, stb.).
Az osztálydiagram jelölései
Az osztálydiagram osztályokból és a közöttük lévő kapcsolatokból, relációkból áll. Az osztály jelölésének általános formája:

[image: image18]
Az attribútumok listájában az osztályhoz tartozó változókat tüntetjük föl. Egy változó bejegyzés (egy sor) kinézete: <láthatóság><változónév> : <változó típusa>.
Az operációk listájában az osztály tagfüggvényeit tüntetjük föl. Ezek általános formája: <láthatóság><függvénynév>(<paraméter lista>) : <visszatérési érték típusa>.
A <láthatóság> lehet „+” (publikus adattag), „#” (védett adattag) vagy „-” (privát adattag).

A <paraméter lista> paraméterek vesszővel elválasztott fölsorolása, ahol egy paraméter alakja: <felhasználás módja = „in”/ „out”/„inout”> <változónév> : <változó típusa>.

A program bemenetének készítéséhez az osztályok közötti relációk típusai közül csak az öröklődésre lesz szükség, ennek jelölése:


[image: image19.emf]általános speciális


Az osztálydiagram létrehozása a Visio programmal
Kétféleképpen hozhatunk létre osztálydiagramot a Visio segítségével. Első és ajánlott mód a visszafejtés (reverse engineering) használata, amely meglévő Microsoft Visual Studio 2005 projektünkből automatikusan készíti el az osztálydiagramot, ehhez a Microsoft Visio for Enterprise Architects programmal is rendelkeznünk kell. A Visual Studio 2005 programban aktiváljuk a

View > Toolbars > Visio UML

eszköztárat, majd miután betöltöttük soros feldolgozású párhuzamosítani kívánt programunkat, a [image: image20.png]


 ikonra kattintva Visio kompatibilis „.vsd” kiterjesztésű fájlt készíthetünk. Ez a fájl már tartalmaz minden információt, ami szükséges az osztálydiagramhoz. A fájlt a Visio alatt megtekintve üres diagram fogad minket, ezen ne lepődjünk meg, az UML diagramra mi tehetjük föl a számunkra szükséges osztályokat, amiket a „Model Explorer” fastruktúrájában az

UML System 2 > Static Model > Top Package > <programunk neve>

alatt találunk. Ha olyan nyelven dolgozunk, amely főprogramot tartalmaz (pl. C++), akkor a Visio a „«utility»Utility” nevet adja egy fiktív osztálynak, amiben a főprogramot mint tagfüggvényt adhatjuk meg, ügyelve a helyes formára.

Amikor az osztálydiagramot készítjük, akkor az öröklődési relációk automatikusan kerülnek a diagramra. Mielőtt befejezzük a munkát, ellenőrizzük, hogy a kész diagram megfelel-e az ismertetett specifikációnak. A beállításokhoz használjuk a Visio beépített segédablakait, hogy szintaktikailag helyes bemeneti programot kapjunk eredményül.
A második osztálydiagram készítési mód a kézi készítés, ekkor a Visio programban a

File > New > Software > UML Model Diagram

menüpontból hozhatunk létre új UML diagramot. Mivel osztálydiagramot szeretnénk készíteni, ezért a diagramhoz az „UML Static Structure” címszó alatti formák (shapes) közül adhatjuk az osztály (class) formát a diagramunkhoz. Az öröklődést az általánosítás (generalization) nyíl alakú forma ábrához adásával érhetjük el, mindenképpen kössük a végpontjait meglévő osztályainkhoz. Az osztályok függvényeit és attribútumait a Visio segédablakaival könnyen hozzáadhatjuk az osztályokhoz.
Munkánkat mentsük el, de ne lépjünk ki, mert most még csak a statikus szerkezet diagramját készítettük el. A program műveleteit folyamatábrákkal fogjuk ábrázolni, melynek elemeit a következő oldalon mutatom be.
Folyamatábra (blokkdiagram) 

Az algoritmusok megadásának legkorábban kialakult megadási módja. Alapjeleit maga Neumann dolgozta ki. Az egyes szerkezeti elemek között nyilakkal jelöljük a végrehajtási sorrendet. Az értékadó utasítás téglalapba, a meghívott folyamat speciális téglalapba, a kiválasztás rombuszba, az adatáramlás parallelogrammába, a vezérlő utasítások lekerekített téglalapba kerülnek. Az ismétlési szerkezeteket a nyilak mentén fedezhetjük föl.
Az elemek és kapcsolatuk a diplomamunkában vázolt program gráffal:
1. Függvény (eljárás) megadás

Külön blokkdiagramot készítünk számára. A kezdőpontja a START, végpontja az END.

[image: image21.png]utasitasok





A kapcsolódó gráfbeli csúcsok a NodeFlowchartStart
[image: image22.png]



és a NodeFlowchartEnd.

[image: image23.png]NodsHlowchartEnd




2. Függvény (eljárás) hívás

[image: image24.png][<osztalyné paraméter lista>])





Az <aktuális paraméter lista> változónevek és értékek vesszővel elválasztott fölsorolása. A [] zárójelek közötti rész esetenként elhagyható.

Kapcsolódó gráfbeli csúcs a NodeFlowchartPredefined.

[image: image25.png]NodeFlowchartPredefined
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3. Adat bevitel

[image: image26.png]<valtozonév lista>




A <változónév lista> vesszővel elválasztott változóneveket tartalmaz, melyek a kapcsolódó függvény paraméter listájában szerepelnek.

Kapcsolódó gráfbeli csúcs a NodeFlowchartIn.

[image: image27.png]



4. Adat kivitel

[image: image28.png]Y
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Kapcsolódó gráfbeli csúcs a NodeFlowchartOut.

[image: image29.png]NodeFlowchartCut
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5. Adat allokáció

[image: image30.png]v
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A <változó bejegyzés lista> vesszővel elválasztott változó bejegyzéseket tartalmaz, melyek kinézete: <változónév> : <változó típusa>.

Kapcsolódó gráfbeli csúcs a NodeFlowchartLocal.

[image: image31.png]NodsFlowehartLocal




6. Értékadás

[image: image32.png]<valtozénév> :





A <kifejezés> egy szabályos aritmetikai kifejezés, amely állhat más változónevekből, értékekből és műveleti jelekből, pl. x := 2 * y.

Kapcsolódó gráfbeli csúcs a NodeFlowchartProcess.
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7. Feltételes elágazás
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Ha a feltétel teljesül, akkor a TRUE utasításblokk kerül végrehajtásra, ha nem, akkor a FALSE. Mindkét esetben folytatódik a program. Megfelel a kétágú feltételnek, a többágú elágazás is összeépíthető belőle.

A <feltétel> valójában egy <változónév vagy érték> <logikai jel> <változónév vagy érték> alakú kifejezés, ahol a <logikai jel> lehet =,<,<=,>,>=,><.

Kapcsolódó gráfbeli csúcs a NodeFlowchartDecision.
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8. Ismétlési szerkezet

A ciklusok a feltételes elágazás segítségével készíthetők.
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Kapcsolódó gráfbeli csúcs itt is a NodeFlowchartDecision.

9. Utasítás sorozat

A nyilak által meghatározott sorrendben kell végrehajtanunk az utasításokat.

A függvények folyamatábráinak létrehozása a Visio programmal
Azon függvényekhez, amelyek nem üresek vagy virtuálisak, hozzunk létre a Visio dokumentumunkban egy-egy új oldalt (page). Az oldalak nevei legyenek <osztálynév>::<függvény deklaráció> alakúak, ahol a <függvény deklaráció> megegyezik az osztálydiagram megfelelő <osztálynév> nevű osztályának az operációk listáján szereplő megfelelő bejegyzéssel a <láthatóság> bejegyzés elhagyásával. Pl. az alábbi osztályleíráshoz
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a megfelelő új oldalnév:

«utility»Utility::_tmain(in argc : int, in argv : _TCHAR*[]) : int.

Ahhoz, hogy folyamatábra elemeket helyezzünk el az új oldalakra, kattintsunk a

File > Shapes > Flowchart > Basic Flowchart Shapes

menüpontra. Ekkor megjelennek a formák (shapes) között „Basic Flowchart Shapes” címszó alatt azon ábrák prototípusai (is), amelyeket eddig megismertünk.

Minden új oldalon szerepelnie kell START és END ábráknak, ahogy az a „Függvény (eljárás) megadás” alatt olvasható. Ehhez a formák közül a „terminator” elemet válasszuk és húzzuk be az ábránkba kétszer, és írjuk beléjük a START ill. END szavakat. A betűtípust szabadon választhatjuk.
Függvény (eljárás) megadás:

Terminator
A többi ábraelemet a programunk alapján helyezhetjük el az ábrába, az alábbi fölsorolás megadja, hogy mely folyamatábra elemhez melyik Visio forma tartozik.
Függvény (eljárás) hívás:

Predefined process
Adat bevitel / kivitel / allokáció:
Data
Értékadás:



Process
Feltételes elágazás:


Decision
Utasítás sorozat (nyíl):


Dynamic connector
A nyilak végződését átállíthatjuk nekünk tetszővé, de fontos, hogy a megfelelő végrehajtási sorrendet mutassák, és mind a kettő végük ábrához legyen kötve. Munkánk végeztével az elkészült dokumentumot XML Drawing (*.vdx) fájlformában mentsük el. Az A függelékben példákon keresztül helyes ábrákat figyelhetünk meg, és láthatjuk, hogy ezekből a program milyen gráfot és párhuzamos programot készített.
Útravaló a program használatához
Kezdjük először egyszerűbb példákkal, pl. az előre telepített, „A” függelékben bemutatottakkal, majd kísérletezhetünk saját készítésű, több osztályt magába foglaló, összetettebb, valóban objektumorientált programokkal.
Miután elkészítettük a párhuzamosítani kívánt program modelljét a Visio segítségével, vagy ha az egyik előre elkészített példával próbálkozunk, kövessük a 2. fejezet 2-8. lépéseit, hogy párhuzamosítsuk, illetve információt szerezzünk a becsült gyorsulásról.

Kilépés
A munka befejeztével a programból kilépni a

File > Exit

menüpontra kattintva tudunk.
A program eltávolítása

A Paralleliser rendszerünkből történő eltávolításához a rendszer szabványos eltávolító folyamatát használjuk. Ez általában a 

Start Menü > Vezérlőpult > Programok telepítése és törlése

menüpontra kattintással indítható el. A programok listájából a Paralleliser nevű program eltávolítását kezdeményezzük. Ekkor lefut egy eltávolító program, amely jelzi, ha végzett a törléssel.

4. FEJEZET
Kapcsolat a fejlesztővel

A program készítőjével a halati@freemail.hu e-mail címen léphet kapcsolatba.

A FÜGGELÉK
A program működésének bemutatása példákon keresztül
A most következő példák egyszerű, rövid programok párhuzamosítását mutatják be. Minden program egy főprogramból áll, ezért az osztálydiagram itt kevésbé fontos, nem fog szerepelni az ábrák között. Minden példa kapcsán láthatjuk a kiindulási program kódját, folyamatábráját, program gráfját, majd az előállított program gráfot és folyamatábrát, valamint az alapértelmezett értékekkel kapott gyorsulást. A példaprogramok betölthetők és párhuzamosíthatók a Paralleliserrel, a 2. fejezetben ismertetett megfelelő lépések végrehajtásával.
1. Példa
Példa neve: Example_1
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Programkód (Microsoft Visual C++) és folyamatábra:

#include "stdafx.h"

int Variable_A;

int Variable_B;

int Variable_C;
int _tmain(
int argc, _TCHAR* argv[])

{


Variable_A = 1;


Variable_B = 2;


Variable_C = 3;


return 0;

}
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Program gráf:

Párhuzamos program gráf:
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Párhuzamos program folyamatábrája:
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Becsült gyorsulás: 375 %

2. Példa
Példa neve: Example_2

Programkód (Microsoft Visual C++) és folyamatábra:

[image: image55.png]


#include "stdafx.h"

int Variable_A;

int Variable_B;

int Variable_C;

int _tmain(
int argc, _TCHAR* argv[])

{


Variable_A = 1;


Variable_B = 2;


Variable_C = 3;


Variable_A = 4;


Variable_B = 5;


Variable_C = 6;


Variable_A = 7;


Variable_B = 8;


Variable_C = 9;


return 0;

}
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Program gráf:
Párhuzamos program gráf:
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Párhuzamos program folyamatábrája:
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Becsült gyorsulás: 366.66 %
3. Példa
Példa neve: Example_3

Programkód (Microsoft Visual C++) és folyamatábra:

[image: image57.png]


#include "stdafx.h"

int Variable_A;

int Variable_B;

int Variable_C;

int _tmain(
int argc, _TCHAR* argv[])

{


Variable_A = 1;


Variable_B = 2;


Variable_C = 3;


Variable_A = 
Variable_B * 2;


return 0;

}
Program gráf:
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Párhuzamos program gráf:

[image: image43.png]



Párhuzamos program folyamatábrája:
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Becsült gyorsulás: 250 %

4. Példa
Példa neve: Example_4

Programkód (Microsoft Visual C++) és folyamatábra:
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#include "stdafx.h"

int Variable_A;

int Variable_B;

int Variable_C;

int _tmain(
int argc, _TCHAR* argv[])

{


Variable_A = 1;


Variable_B = 2;


Variable_C = Variable_A;


Variable_A = Variable_B;


Variable_B = Variable_C;


return 0;

}
Program gráf:
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Párhuzamos program gráf:
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Párhuzamos program folyamatábrája:
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Becsült gyorsulás: 175 %

5. Példa
Példa neve: Example_5

Programkód (Microsoft Visual C++):

#include "stdafx.h"

int Variable_A;

int Variable_B;

int Variable_C;

int _tmain(int argc, _TCHAR* argv[])

{


Variable_A = 1;


Variable_B = 2;


Variable_C = 3;


if ( Variable_A == Variable_B )


{



Variable_A = Variable_A + 1;



Variable_B = Variable_A;



Variable_C = Variable_A;



Variable_A = Variable_B * Variable_C;


}


else


{



Variable_A = 4;



Variable_B = 5;



Variable_C = Variable_A + Variable_B;


}


return 0;

}
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Folyamatábra:
[image: image60.png]


Program gráf:

Párhuzamos program gráf:
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Párhuzamos program folyamatábrája:
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Becsült gyorsulás: 147.82 %

6. Példa
Példa neve: Example_6

Programkód (Microsoft Visual C++):

#include "stdafx.h"

int Variable_A;

int Variable_B;

int _tmain(int argc, _TCHAR* argv[])

{


Variable_A = 0;


Variable_B = 1;


while (Variable_B < 10)


{



Variable_A = Variable_A * 2;



Variable_B = Variable_B + 1;


}


return Variable_A;

}
Folyamatábra:
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Program gráf:
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Párhuzamos program gráf:

[image: image52.png]



Párhuzamos program folyamatábrája:
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Becsült gyorsulás: 166.66 %
<név>








<attribútumok listája>





<operációk listája>











� Rozgonyi-Borus Ferenc: RAM-ba zárt világ, [296], ISBN-963-697-153-6 és a Visio leírása alapján. 
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Absztrakt soros feldolgozású objektumelvű program UML segítségével ábrázolva.
Fájlformája Visio kompatíbilis XML.


Absztrakt program gráf, melyben nyilvántartottak az objektumok, illetve az utasítások sorrendje.
Megvalósítása programban


Absztrakt program gráf, melyben nyilvántartottak a párhuzamos környezetbeli objektumok és az utasítások függése,párhuzamossága.
Megvalósítása programban.


Absztrakt párhuzamos feldolgozású objektumelvű program UML segítségével ábrázolva.
Fájlformája Visio kompatíbilis XML.
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